Cloud Help Desk - Ticket queues not loading or server error page

Incident Report for Spiceworks

Resolved

No further issues have been detected. The engineering team is analyzing the root cause to ensure future stability before the code change is redeployed.
Posted May 27, 2026 - 14:51 CDT

Monitoring

The rollback is completed and performance has returned to normal. If you are still seeing the issue please let us know at support@spiceworks.com
Posted May 27, 2026 - 10:45 CDT

Identified

We're rolling back the underlying tech change from this morning as it is causing the performance issue.
Posted May 27, 2026 - 09:44 CDT

Investigating

Engineering and our ops team are investigating reports where an "oops" error page is displayed intermittently, along with the page loading but failing to display any tickets.
Posted May 27, 2026 - 08:07 CDT
This incident affected: Cloud Help Desk.