Cloud Help Desk outage

Incident Report for Spiceworks

Resolved

This has now been resolved.
Posted Oct 21, 2025 - 02:41 CDT

Monitoring

Cloud Help Desk has been affected by the issues with Amazon Web Services https://health.aws.amazon.com/health/status. Amazon has reported that most requests are now completing and in our testing Cloud Help Desk is back up and running. We are continuing to monitor the situtation.
Posted Oct 20, 2025 - 04:55 CDT
This incident affected: Cloud Help Desk.