Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 31, 2026 - 07:30 CST
Scheduled
We will be performing scheduled database maintenance and infrastructure cleanup to optimize system performance. To ensure a smooth process, the services listed below will be briefly unavailable during this window.
• Impacted Services: Cloud Help Desk (CHD) and Spiceworks Cloud Tools & Apps. • Email Processing: Outbound system notifications will be disabled during this window and will not be backfilled once maintenance is complete. This will not affect inbound user-submitted emails for ticket creation in CHD. • Start Time: Saturday, Jan 31, at 7:30 AM CST / 13:30 UTC • Estimated Duration: Less than 120 minutes.
While we have reserved a two-hour window, we expect the actual downtime to be significantly shorter. We will provide a final update here once services have been thoroughly verified and are back online.
Posted Jan 30, 2026 - 10:51 CST
This scheduled maintenance affected: Cloud Help Desk, Connectivity Dashboard, and Inventory Online.