Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 22, 2025 - 23:30 CDT
Scheduled
What’s Changing for Your Login? These updates specifically affect members who log in using an email address and password across our key platforms: Community, Cloud Help Desk (CHD), Inventory Online, Connectivity Dashboard, and Contracts.
1. Mandatory Password Update For better security, we’re introducing a required password refresh for some accounts:
What’s Happening: If you haven’t changed your password in the last six months, you will be prompted to change it the next time you log in. To make it even easier, we’ll automatically send you the password reset link via email straight to your inbox. Why? This helps ensure your credentials remain protected. You’ll be using the stricter password requirements we introduced last year, which are designed to keep your account safer.
2. Account Inactivity Lock To further protect accounts that may no longer be in active use, we’re implementing an inactivity policy:
What’s Happening: Accounts that we believe haven’t been used for over a year will be temporarily locked. What if my account is locked? Don’t worry, unlocking it is easy! You can regain access immediately by using the “Forgot Password” feature on the login screen. Why? This ensures that only you can regain access, as the password reset link will be sent directly to your registered email address. This prevents unused accounts from becoming a security risk.
These steps are all part of our ongoing effort to provide you with the most secure experience possible. We appreciate your cooperation in helping us keep your accounts and our community safe!
Posted Oct 17, 2025 - 09:43 CDT
This scheduled maintenance affected: Spiceworks Community, Cloud Help Desk, Connectivity Dashboard, and Inventory Online.