Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 11, 2025 - 22:30 CDT
Scheduled
A necessary database upgrade will be performed during this time.
Logged in community users will be unaffected, but new logins will not work.
Tools and Apps will be inaccessible during this maintenance period, but no data will be lost Inbound emails for cloud help desk will be processed either during or immediately after the maintenance period has concluded.
Posted Apr 10, 2025 - 10:32 CDT
This scheduled maintenance affected: Spiceworks Community, Cloud Help Desk, Connectivity Dashboard, and Inventory Online.