Cloud Help Desk - Ticket imports failing
Incident Report for Spiceworks
Resolved
Imports with greater than 5000 tickets are failing, even when under the documented file size limit. The main use for this feature is to import from the legacy help desk which was discontinued in 2021. Due to this, further development time cannot be committed to fully address this issue.

A workaround reported by some users has been to split up the import file. A bash script that can be used for this purpose can be found at https://community.spiceworks.com/scripts/show/5263-spiceworks-json-export-file-splitter

You can use your own method for splitting the file, though note that the following json arrays need to be present in order for every file:

sites
custom_attributes
inventory_ticket_relations
tickets
users

When you have the split files, head over to the Cloud Help Desk Setting page:
Select Import/export tickets
Choose the first file to upload e.g. split_export_1.json
Ensure "Keep the same ticket numbers" is not selected
Click "Continue import"
Check the import log link to see the progress of the import
Once the import is complete you can add the next file in the same manner
Keep adding files until you have imported all of your tickets
Posted Apr 18, 2023 - 14:48 CDT
Investigating
We're getting reports of ticket import jobs failing. The development team is looking into the cause.

Failing imports are unlikely to succeed until this issue is resolved or a workaround found, so we recommend not retrying the same data if your initial import fails to complete. A new import with a smaller subset of tickets may be successful in the meantime.
Posted Mar 31, 2023 - 12:56 CDT
This incident affected: Cloud Help Desk.