Heavy Email Load Impacting Cloud Help Desk
Incident Report for Spiceworks
Resolved
We have implemented both automated and manual - if needed - methods of blocking spam accounts which we anticipate will greatly reduce or eliminate the sort of attacks we've been seeing over the last week or so.
Posted Nov 12, 2019 - 15:12 CST
Monitoring
The mail flow issues have subsided - work continues on several fronts to reinforce spam prevention.
Posted Nov 08, 2019 - 10:12 CST
Investigating
Spam bots have been hitting our help desk users in the last week, causing unnecessary ticket creation and mail flow delays. We’ve been working with our mail provider on a solution, and are also investigating ways to mitigate this app-side. Subscribe to this page for updates.
Posted Nov 07, 2019 - 09:35 CST
This incident affected: Cloud Help Desk.