We have seen no further reports of latency or timeouts, and our internal testing confirms that performance remains stable. We are now officially marking this incident as Resolved.
Root Cause: The issue was triggered by a high-volume surge of API requests from a third-party data tool. This created an unexpected load on our database, specifically impacting the ticket queue and reporting sections.
Prevention: To prevent a recurrence, we have implemented new traffic controls and rate-limiting measures. We will continue to monitor these systems to ensure long-term stability.
If you are still experiencing any issues, please let our team know at support@spiceworks.com.
Posted Apr 30, 2026 - 13:03 CDT
Monitoring
We have successfully stabilized the Cloud Help Desk. Our teams will be monitoring for any further issues and investigating the root cause. Please submit a ticket via support@spiceworks.com if you still encounter excessive latency or timeouts.
Posted Apr 28, 2026 - 14:07 CDT
Investigating
We're investigating reports of slow performance and timeouts on the Cloud Help Desk. We've confirmed this is a system-side issue and are working on a fix. Updates to follow.