Cloud Help Desk - Reports of slow inbound email processing
Incident Report for Spiceworks
Resolved
Our email service provider implemented changes that resolved the inbound email delays, which had increased in severity on May 18. We confirmed delivery times normalized following this fix.
Posted May 26, 2020 - 13:38 CDT
Update
We have reports for the past couple of days that delays with mail have increased in some cases to over an hour.

For urgent tickets, consider using the ticket portal which allows for instant ticket submission (though replies from the user by email will still potentially be delayed).
Posted May 18, 2020 - 10:48 CDT
Update
Work continues to resolve this issue.
Posted May 06, 2020 - 07:15 CDT
Identified
The secondary problem we're seeing appears to be making the email delays worse at this time. The development team is working on alleviating this as a top priority.
Posted May 05, 2020 - 11:43 CDT
Update
We are continuing to work with our mail providers support team on this issue.
Posted Mar 09, 2020 - 11:15 CDT
Investigating
Emails sent to the cloud help desk are taking excessive time to be processed into tickets. We believe this issue to be related to our mail processor and are working with their support staff to find a resolution.
Posted Mar 06, 2020 - 11:50 CST
This incident affected: Cloud Help Desk.