Cloud Help Desk Premium Plan is now live

Scheduled for Jul 1, 00:30 - 01:30 CDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 04, 2025 - 07:36 CDT

Scheduled

Since July 1, 2025, accounts with six (6) or more active employee seats were required to upgrade to the Premium Plan to maintain full functionality.

To avoid disruption, we temporarily allowed continued email ticketing for accounts that hadn't yet upgraded. However, starting August 11, 2025, we will begin disabling email addresses for accounts that remain over the free tier limit and have not upgraded.

How do I restore my account to full access?
To restore full access, an admin or owner must either reduce the number of active seats to five (5) or fewer, or upgrade to a premium plan.

We have a payment FAQ at: https://www.spiceworks.com/support/help-desk-cloud-edition/docs/#pp-faq

If you need assistance upgrading to a subscription - Please contact us at subscriptions@spiceworks.com.

For technical issues or inquiries, use support@spiceworks.com.
Posted Aug 04, 2025 - 07:30 CDT
This scheduled maintenance affects: Cloud Help Desk.