Connectivity Dashboard - "data did not load!" error displayed

Incident Report for Spiceworks

Resolved

Engineering were able to establish the root cause of this issue and implement a fix. Testing shows normal service is restored.
If you're still seeing issues, try clearing your browser cache first. If the error still occurs, please open a ticket at support@spiceworks.com
Posted Oct 08, 2025 - 09:52 CDT

Investigating

We're seeing reports that the management web page for connectivity dashboard is failing to load. Engineering have been made aware and are investigating.
Posted Oct 08, 2025 - 09:10 CDT
This incident affected: Connectivity Dashboard.