New cloud help desk email addresses return "550 No Such User" error

Incident Report for Spiceworks

Resolved

The issue has been resolved for new accounts. All affected existing accounts have been fixed where needed.

Please email support@spiceworks.com if you email your new help@orgname.on.spiceworks.com address and get a "550 No Such User" response.
Posted Apr 03, 2024 - 13:02 CDT

Investigating

We have reports that new cloud help desk accounts return the above error when emails are sent to the help@orgname.on.spiceworks.com address. The development team is looking into the cause.
Posted Apr 03, 2024 - 09:49 CDT
This incident affected: Cloud Help Desk.