Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 20, 2025 - 00:00 CDT
Scheduled
Starting at approximately Midnight CDT (5am UTC) on Mar 20, 2025, we will perform maintenance on the Settings page for Spiceworks Cloud Help Desk (CHD).
We anticipate this downtime to take no more than 2 hours.
During this maintenance the Settings page will be unavailable and will display a maintenance mode page.
No other aspects of cloud help desk will be affected.
No data will be lost, email processing and all other CHD functions will continue as normal.
To keep up-to-date with our progress or any changes, keep an eye here on our Status Page. We appreciate your patience and understanding.
Posted Mar 19, 2025 - 07:16 CDT
This scheduled maintenance affects: Cloud Help Desk.