We have been monitoring a fix for this issue which appears to have been successful. Please email support@spiceworks.com if you are still having issues.
Posted Feb 25, 2025 - 09:19 CST
Investigating
Our engineering teams are investigating an issue where some Spiceworks emails are not being sent out.
Cloud help desk emails for tickets are unaffected as these use a different system.
Posted Feb 20, 2025 - 07:50 CST
This incident affected: Spiceworks Website, Spiceworks Community, and Cloud Help Desk.