Cloud Help Desk - MFA deliverability issues for some users

Incident Report for Spiceworks

Resolved

We're seeing lower ticket volumes today and it appears email filters are getting "used" to the new emails. If you are still having issues, let us know at support@spiceworks.com
Posted Mar 21, 2025 - 08:16 CDT

Investigating

While trying to improve deliverability of these emails, we wanted to communicate two things to folks which may help.

1. If you are stuck with a locked account from retrying codes or getting MFA emails in the wrong order, doing a password reset from our login page and changing your password will also unlock the account. This will save you waiting on support to unlock your account.

2. If you use Mimecast, its "greylisting" feature may be delaying these new MFA emails. More on that here https://community.spiceworks.com/t/cloud-help-desk-release-notes-mar-19-2025-mfa-for-cloud-help-desk-employee-accounts-is-here/1186674/14?u=craig-spiceworks
Posted Mar 20, 2025 - 08:57 CDT
This incident affected: Cloud Help Desk.