We have monitored the system and confirmed that notification delivery has returned to normal. As a result, we are marking this issue resolved.
Note on Duplicates: Because of the way our retry logic handled the initial delays, some users may receive 1-2 duplicate notifications for older tickets. We appreciate your patience with this temporary "noise".
If you continue to experience new delays, please contact us at support@spiceworks.com so we can investigate further.
Posted Mar 03, 2026 - 14:52 CST
Monitoring
A fix has been deployed and the underlying issue is resolved. We are currently processing a backlog of delayed notifications. Delivery times will return to normal once the queue has cleared. Engineering is actively monitoring the recovery and has scaled resources to accelerate processing.
Posted Mar 03, 2026 - 12:29 CST
Investigating
We've received reports of email notifications for tickets being delayed. Engineering are investigating the issue.