Cloud Help Desk - Slow page load and timeouts
Incident Report for Spiceworks
Resolved
We identified some queries that were causing a lock on the database and degrading response times. This has been cleared and performance is now returning to normal.
Posted Nov 18, 2019 - 10:39 CST
Investigating
We've noticed some poor page load times/timeouts and are currently investigating.
Posted Nov 18, 2019 - 09:20 CST
This incident affected: Cloud Help Desk.