Verification is currently underway for the maintenance items.
Posted Jul 22, 2024 - 18:10 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 22, 2024 - 17:30 CDT
Scheduled
The Cloud Help Desk will have a maintenance outage during this period for backend service improvements.
While CHD may be inaccessible during this maintenance period, no data will be lost, and inbound emails will be processed either during or immediately after the maintenance period has concluded.
To stay up-to-date with our progress or any changes, subscribe and keep an eye on our Status Page.
We appreciate your patience and understanding.
Posted Jul 19, 2024 - 12:47 CDT
This scheduled maintenance affected: Cloud Help Desk.