Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 18, 2025 - 23:30 CDT
Scheduled
We're completing essential maintenance on our transactional email infrastructure. During this time, the following will be impacted:
Multi-Factor Authentication (MFA) for login will be temporarily disabled. You'll still be able to log in using your username and password / social login, but the second authentication step won't be required.
New account registration suspended. We'll temporarily pause new sign-ups during the maintenance window.
We anticipate minimal disruption to other services. This status will be updated once the maintenance is complete.
Thank you for your understanding.
Posted Jul 17, 2025 - 15:13 CDT
This scheduled maintenance affected: Spiceworks Community, Cloud Help Desk, Connectivity Dashboard, and Inventory Online.