Cloud Help Desk - Power BI reporting connector login issue
Incident Report for Spiceworks
Resolved
Setting Power BI to use a default web browser has resolved the login issue for users who raised support ticket. We recommend this as the standard configuration going forward.
In Power BI, go to File > Options And Settings > Options > Security > Scroll down to "Authentication Browser" > Enable "Use my default browser".
Posted Apr 12, 2023 - 15:19 CDT
Update
Dave4564 on the community shared a workaround for those folks not getting the login box or being unable to delete old credentials:
In Power BI, go to File > Options And Settings > Options > Security > Scroll down to "Authentication Browser" > Enable "Use my default browser"

When you try to refresh the data now, the login should open up in a browser window and allow you to log in.
Posted Apr 03, 2023 - 14:31 CDT
Investigating
We are investigating reports that in some cases the Power BI connector is no longer able to log in to retrieve reporting information.
Posted Apr 03, 2023 - 12:23 CDT
This incident affected: Cloud Help Desk.