Cloud Help Desk 30-31/Oct/2018
Incident Report for Spiceworks
Resolved
A fix was released last night that resolves this issue.
Posted Nov 01, 2018 - 10:26 CDT
Identified
We've identified a minor issue with the Cloud Help Desk new account signup process that we're working to resolve. The issue is limited to certain new signups (regional and based on user account state).
Posted Oct 31, 2018 - 11:46 CDT
This incident affected: Cloud Help Desk.