Cloud Help Desk - 13/Sept/2018
Incident Report for Spiceworks
Resolved
We have continued monitoring over the past 90 minutes and are no longer seeing email delays or delivery issues.
Posted Sep 13, 2018 - 10:02 CDT
Monitoring
We've implemented a fix and email is flowing - we will continue monitoring for the next few hours. There was an issue with our edge provider blocking inbound mail requests and we have circumvented.
Posted Sep 13, 2018 - 08:34 CDT
Investigating
There are multiple reports of inbound email delivery issues (ticket creation and updates via email). We are actively investigating the issue and we'll provide updates as available.
Posted Sep 13, 2018 - 07:53 CDT
This incident affected: Cloud Help Desk.