Cloud Help Desk Outage - 05/15/2018
Incident Report for Spiceworks
Resolved
The Cloud Help Desk has remained stable following our resolution about 2 hours ago. This incident is now closed out.
Posted May 15, 2018 - 13:16 CDT
Monitoring
We've resolved the issues and the Cloud Help Desk is back online.
Posted May 15, 2018 - 11:23 CDT
Investigating
Developers are investigating the Cloud Help Desk 50x errors.
Posted May 15, 2018 - 08:48 CDT
This incident affected: Cloud Help Desk.