Cloud Help Desk - 2018-01-18
Incident Report for Spiceworks
Resolved
This incident has been resolved.
Posted Jan 18, 2018 - 11:41 CST
Investigating
We've received reports of users who are having issues accessing file attachments in the Cloud Help Desk (ticket attachments, report exports). We are actively investigating the issue and we'll provide updates as available.
Posted Jan 18, 2018 - 11:28 CST