Cloud Help Desk Outage - 7/17/2019
Incident Report for Spiceworks
Resolved
We've resolved the technical issues and our cloud help desk app is back online.
Posted Jul 17, 2018 - 13:56 CDT
Update
We are continuing to investigate this issue.
Posted Jul 17, 2018 - 13:30 CDT
Investigating
Our Cloud Help Desk application is experiencing an outage due to some technical issues, but our engineers are currently investigating.
Posted Jul 17, 2018 - 13:23 CDT
This incident affected: Cloud Help Desk.