WWW and Cloud Help Desk: Regional Access Issues
Incident Report for Spiceworks
Postmortem

Upon further investigation we discovered the root issue causing login failures to be a problem passing properly formatted HTTP headers between our CDN and the Cloud Help Desk. We released a change to the Cloud Help Desk to workaround this issue, which we believe was introduced by changes at the CDN level. We have not been receiving any new related reports of login issues.

Posted May 18, 2018 - 12:11 CDT

Resolved
This issue has been resolved. Some users from specific ISP's were not able to access Spiceworks products. We are addressing these issues with each user individually.
Posted May 16, 2018 - 13:47 CDT
Investigating
We are investigating reports of issues accessing www and/or logging in to the Cloud Help Desk from specific regions outside North America.
Posted May 16, 2018 - 10:59 CDT
This incident affected: Spiceworks Website and Cloud Help Desk.